MacOS X EL Capitan Wineskin-Umgebung

Fragen und Anregungen zur NotenBox unter macOS / OS X
Antworten
bernd_naumann
Beiträge: 4
Registriert: 28.05.2010, 08:32

MacOS X EL Capitan Wineskin-Umgebung

Beitrag von bernd_naumann » 01.03.2016, 17:41

Sehr geehrter Herr Winter,

auf meinem iMac läuft die NotenBox leider immer schlechter. Mittlerweile ist es mir sogar unmöglich, zweistellige Oberstufennoten einzugeben. Es scheint ein Frame-Problem zu sein, das sich auch mit der Änderung der Schriftgröße nicht beheben lässt. Im Internet habe ich bei Wineskin nur einen Eintrag zur Notenbox ausfindig machen können und zwar Ihr Dankeschön an die Softwarefirma von 2013.
Ich werde wohl zum nächsten Schuljahr auf das TeacherTool umsteigen müssen, das ich bisher stiefmütterlich behandelt habe. Aber ich habe einfach Angst davor, dass ich irgendwann einen irreparablen Datenverlust erleide. Bis jetzt funktioniert wenigstens die Synchronisation noch zuverlässig.

Mit freundlichen Grüßen
Bernd Naumann

Benutzeravatar
Andreas Winter
Beiträge: 1387
Registriert: 28.10.2005, 18:12

Re: MacOS X EL Capitan Wineskin-Umgebung

Beitrag von Andreas Winter » 18.03.2016, 15:49

Sehr geehrter Herr Naumann,
vielen Dank für die Info. Ich habe jetzt das Verhalten nochmals selbst getestet. Auf kleineren Bildschirmen macht die NotenBox die Spalte für die Noteneingabe zu schmal, so dass während der Eingabe von z.B. 12 Notenpunkten jeweils nur die 1 bzw. danach die 2 zu sehen ist. Nach betätigen der Eingabetaste wird dann aber die komplette 12 sichtbar. Ist das in Ihrem Fall auch so?
Wir werden die Unstimmigkeit mit dem nächsten Update beheben. Das Problem ist in der NotenBox selbst und hat nichts direkt mit der Wineskin Umgebung zu tun.

Herzliche Grüße, Andreas Winter

bernd_naumann
Beiträge: 4
Registriert: 28.05.2010, 08:32

Re: MacOS X EL Capitan Wineskin-Umgebung

Beitrag von bernd_naumann » 25.03.2016, 19:04

Sehr geehrter Herr Winter,
vielen Dank für die Antwort. Auch bei mir wird nach Betätigen der Eingabetaste die zweistellige Ziffer sichtbar. Ein Problem weniger :-)
Aber einige andere Probleme bleiben, wie z. B. dieses: Gebe ich bei einstelligen Notenwerten ein +Zeichen oder ein -Zeichen ein, so wird in der Standardeinstellung alles korrekt angezeigt. Da in unserem Bundesland aber diese Zeichen grundsätzlich nicht mathematisch eingerechnet werden dürfen, habe ich auf die Option "+ und - bei der Berechnung nicht berücksichtigen" umgestellt. Danach waren die + und -Zeichen nicht mehr zu sehen und man konnte sie auch nicht mehr eingeben. Als ich die Werte bei + in ,6 umrechnen und bei - in ,1 umrechnen umstellte, zeigte die Eingabemaske bei Minus korrekt an, bei Plus aber nur den Umrechnungswert, z. B. 3- korrekt, aber 1,9 anstatt 2+. Was mache ich falsch? Ich bin der festen Überzeugung, dass ich unter Windows nicht dieses Problem hatte.
Es wäre nett, wenn Sie mir auch zu diesem Problem eine Antwort geben könnten, denn ich vergebe weiterhin + und - auf den Arbeiten, kann diese aber nicht mehr in der Notenbox eintragen.

Ein frohes und gesegnetes Osterfest wünscht Ihnen und Ihrer Familie
Bernd Naumann

Benutzeravatar
Andreas Winter
Beiträge: 1387
Registriert: 28.10.2005, 18:12

Re: MacOS X EL Capitan Wineskin-Umgebung

Beitrag von Andreas Winter » 11.04.2016, 11:44

Sehr geehrter Herr Naumann,
warum + und - zwischendurch nicht angezeigt wurden, ist mir auch nicht klar. War das in der Noteneingabe oder in einer Liste und was war zu diesem Zeitpunkt die Einstellung in "+ in.." und "- in .. " umrechnen?
Falls Sie tatsächlich, wie beschrieben, für + in ,6 umrechnen eingestellt hatten, dann war das der Fehler. Logisch zu "- in 0,1 umrechnen" ist eigentlich "+ in 0,9" umrechnen. Dann sollte die NotenBox 1,9 auch wieder als 2+ anzeigen.

Herzliche Grüße, Andreas Winter

bernd_naumann
Beiträge: 4
Registriert: 28.05.2010, 08:32

Re: MacOS X EL Capitan Wineskin-Umgebung

Beitrag von bernd_naumann » 22.06.2016, 19:14

Sehr geehrter Herr Winter,

vielen Dank für die Antwort.
Nachdem das Abitur fast vorüber ist, hatte ich wieder ein wenig Zeit, an meiner Notenbox zu „schrauben“.

Da mich Ihre Logik überzeugt hat, hatte ich heute vor, in den „Noteneinstellungen“ zu den Standardeinstellungen zurückzukehren. Die meisten Klassen lassen sich problemlos einstellen, ein paar aber „verweigern“ sich hartnäckig. Was ich in „Noteneinstellungen“ auch unter + und – einstelle, es wird NICHT übernommen. Nach dem Schließen der Klassendatei und erneutem Öffnen werden immer die alten Einstellungen angezeigt. Auch das Schließen und Öffnen der kompletten Notenbox führt keine Änderung herbei.

Sind diese Klassen fehlerhaft und müsste ich sie demnach löschen und neu anlegen? Und könnte diese Fehlerhaftigkeit der Klassendateien auch der Grund für mein Problem mit + und - sein?

Mit freundlichen Grüßen
Bernd Naumann

Antworten